苹果从Xcode 8开始对于Alcatraz中安装的插件已经不支持,这可能是因为Xcode-ghost事件,让苹果认为未审核过的插件也会不安全,因此苹果在Xcode 8 中提供了开发插件的扩展.
Using and Extending the Xcode Source Editor.但是我们使用插件已经习惯性和方便,所以本章节为在Xcode 8 中安装Alcatraz

更新2016-11-02

请运行一次官方Xcode8,再打开此插件生成的Xcode版本.

1.安装

通过以下命令安装xcode plugins

1
sudo gem install update_xcode_plugins

2.使用

如果安装好了,可以使用以下再命令行中查看

1
update_xcode_plugins

3.使用插件

当确认安装好以后,通过提示运行以下命令,默认颜色是选择Cancel,可以通过使用键盘上下键,来选择Xcode 8.0等待安装.此安装会等待长时间,因为相当于copy一份Xcode.

1
update_xcode_plugins --unsign

4.安装成功

当安装成功以后会给你跳出Finished!,你可以到你应用程序或者Launchpad中查看到一个Xcode-unsign命名的Xcode版本.打开此版本即可.

###工具
update_xcode_plugins